We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 13:30 UTC
Identified
There is a global internet outage caused by a major provider, Cloudflare. We are awaiting a fix from the provider, and the service will be impacted until it is resolved. https://www.bbc.co.uk/news/articles/c629pny4gl7o
Posted Nov 18, 2025 - 13:27 UTC
This incident affected: Real Talk Studio Roleplays.